Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raid is healthy but all files gone?
I have a 10tb drive as JBOD in my first raid volume.  4x4tb Raid 5 in my second raid volume.   Two raid volumes, the jbod 10tb drive is dev/md0, i gave it the identity "Drive 1" and is the "master raid" with all the modules and system folders.

I tried enabling NFS on "drive1" experimented with it and then decided I didn't want it so I removed the nfs share.  I rebooted the NAS and discovered all the data on "drive 1" is gone!  The master raid system folders and modules etc are still there, but my "drive 1" share is empty.
It's like it was all deleted when I removed the NFS share!  Funny thing is as soon as I removed the share I heard the drive start spinning and seeking for like 5 minutes before the removal action finished, I thought it was removing nfs permissions or something, but I guess it was deleting everything!

I had 8 terabytes out of 10 terabytes, now its 6 gigabytes out of 10 terabytes!  Raid volume appears healthy.  of course I'm not going to write any files, because I need to find a way to recover my data.  unfortunately my transmission torrent module automatically wrote a downloads folder as it autostarted on boot up and tried to resume my torrents.

I have backups of alot of the data but not all.   I could use testdisk to recover deleted partitions but that would mean I'd have to remove the drive and add it to a linux computer.  Although, the jbod raid volume is intact on the NAS, and I would lose that also if I removed the drive and installed it on a linux machine.  

so I feel like it would make more sense to run testdisk on the NAS directly via commandline.  having trouble building testdisk for the n5550.

any help or advice would be appreciated!
Dear Sir,

Seem it it related to APP level, and please check any process or connection link to the NAS, and check what kind of file missing, could be some clues about this issue.

Forum Jump:

Users browsing this thread: 1 Guest(s)