Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Python2][2.05.05] Programming Language
#31
Links has been updated
-----------------------------------------------------------------------------------------------------
[Image: linkedinbutton.jpg]
Download modules from my forum pirinel.ro
Reply
#32
Any chance to have the x86 version of this? Pretty please ? Smile
Reply
#33
x86 require cross compile, i am busy to do it but will take some time. I will let you know when is ready so you can test it.
-----------------------------------------------------------------------------------------------------
[Image: linkedinbutton.jpg]
Download modules from my forum pirinel.ro
Reply
#34
x86 require cross compile, i am busy to do it but will take some time. I will let you know when is ready so you can test it.
-----------------------------------------------------------------------------------------------------
[Image: linkedinbutton.jpg]
Download modules from my forum pirinel.ro
Reply
#35
If you have a guide on howto build the x64 version, I'm ready to spend some time into getting working for x86.
I managed to get the latest CouchPotato running on pyOpenSSL 0.11 for the moment so I'm in no hurry anyway Smile
Reply
#36
If you have a guide on howto build the x64 version, I'm ready to spend some time into getting working for x86.
I managed to get the latest CouchPotato running on pyOpenSSL 0.11 for the moment so I'm in no hurry anyway Smile
Reply
#37
Much appreciate if you can enlighten how you managed to get CouchPotato running on pyOpenSSL 0.11?
Reply
#38
Much appreciate if you can enlighten how you managed to get CouchPotato running on pyOpenSSL 0.11?
Reply
#39
Added x86 version for test, please give feedback after install. ModBase1 1.06.01 need to be installed as a dependency
-----------------------------------------------------------------------------------------------------
[Image: linkedinbutton.jpg]
Download modules from my forum pirinel.ro
Reply
#40
Added x86 version for test, please give feedback after install. ModBase1 1.06.01 need to be installed as a dependency
-----------------------------------------------------------------------------------------------------
[Image: linkedinbutton.jpg]
Download modules from my forum pirinel.ro
Reply
#41
looking forward to testing although I don't see the download links please advise?

Thanks for your time and effort thus far.
Reply
#42
looking forward to testing although I don't see the download links please advise?

Thanks for your time and effort thus far.
Reply
#43
It's a dirty hack. Couchpotato uses a new features from pyOpenSSL which does not seem require.
All you need to do is manually edit the file to remove the guilty line.
Code:
diff --git a/libs/requests/packages/urllib3/contrib/pyopenssl.py b/libs/requests/packages/urllib3/contrib/pyopenssl.py
index b2c34a8..df6481c 100644
--- a/libs/requests/packages/urllib3/contrib/pyopenssl.py
+++ b/libs/requests/packages/urllib3/contrib/pyopenssl.py
@@ -276,7 +276,7 @@ def ssl_wrap_socket(sock, keyfile=None, certfile=None, cert_reqs=None,
     ctx.set_cipher_list(DEFAULT_SSL_CIPHER_LIST)

     cnx = OpenSSL.SSL.Connection(ctx, sock)
-    cnx.set_tlsext_host_name(server_hostname)
+    #cnx.set_tlsext_host_name(server_hostname)
     cnx.set_connect_state()
     while True:
         try:
The logs still has errors about the wrong version, but it works
Reply
#44
It's a dirty hack. Couchpotato uses a new features from pyOpenSSL which does not seem require.
All you need to do is manually edit the file to remove the guilty line.
Code:
diff --git a/libs/requests/packages/urllib3/contrib/pyopenssl.py b/libs/requests/packages/urllib3/contrib/pyopenssl.py
index b2c34a8..df6481c 100644
--- a/libs/requests/packages/urllib3/contrib/pyopenssl.py
+++ b/libs/requests/packages/urllib3/contrib/pyopenssl.py
@@ -276,7 +276,7 @@ def ssl_wrap_socket(sock, keyfile=None, certfile=None, cert_reqs=None,
     ctx.set_cipher_list(DEFAULT_SSL_CIPHER_LIST)

     cnx = OpenSSL.SSL.Connection(ctx, sock)
-    cnx.set_tlsext_host_name(server_hostname)
+    #cnx.set_tlsext_host_name(server_hostname)
     cnx.set_connect_state()
     while True:
         try:
The logs still has errors about the wrong version, but it works
Reply
#45
Thanks,

FYI, I note the links for the x86 versions are located at the start of the thread, just downloading now I'll let you know how I go...
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Python2] [2.00.01] Module released fajo 52 17,102 09-20-2013, 04:57 AM
Last Post: Roelski
  Issue with Python2 module (1.00.03) romanoskovitch 25 6,734 10-19-2012, 04:53 PM
Last Post: romanoskovitch
  [Python2] issue [solved] scavenger 4 2,157 02-23-2012, 06:44 AM
Last Post: scavenger
  [Python2] Module released (1.00.03) fajo 0 1,205 02-20-2012, 06:09 AM
Last Post: fajo
  [Python2] Module updated (1.00.01) fajo 1 1,510 10-10-2011, 08:23 PM
Last Post: Qoolbox
  Issue with Python2 module (1.00.03) 0 2,767 Less than 1 minute ago
Last Post:
  [Python2 x86 & x64][2.02.02] 0 3,087 Less than 1 minute ago
Last Post:

Forum Jump:


Users browsing this thread: 1 Guest(s)