Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Data Guard] Problem Connecting to DeltaCopy Server
#1
I am trying to backup from my N2310 (OS Version OS6.0.827 using Data Guard as the backup Client) to a Windows Vista PC running DeltaCopy Server. When I test the connection Data Guard gives the error message "Target has not appoint Folder"
The Client (N2310) and server (Vista PC running DeltaCopy Server) are both on the same LAN segment and the widows firewall is set to allow traffic on Port 873 using TCP.
There was a similar post in 2013 [ <!-- l --><a class="postlink-local" href="http://forum.thecus.com/viewtopic.php?f=71&t=6451">viewtopic.php?f=71&t=6451</a><!-- l --> ] re trying use use Data Guard to backup to a FReeNAS. This did not seem to be resolved.
Please help.
Reply
#2
Hey there, I realize its been almost a year since you posted. But, I only ran into your unanswered question while searching for help with a similar problem. I looked long and hard and found nothing but people with the same issue and no solutions. So I solved it myself.
I too tried Data Guard and had the same issue - although I was attempting to rsync my Thecus with a Nas4free rsync server. Same thing really, standard rsync implementation. The broken english error you receive is no help. I moved on to trying an rsync Thecus App called "Rsync Backup". From which I received a very similar broken english error. Unfortunately it doesn't look like this app is available for your platform - I am running an N5550 v2.05.12 - but I think the fix may still be applicable to Data Guard.
I found in the logs of my Nas4free backup target that the Thecus was attempting to modify times on directories which Nas4free did not allow. Tried modifying permissions, didn't help. SO, I decided to modify the Thecus' rsync code. I found that there is an rsync option:
Code:
-O (or --omit-dir-times)
This is an Uppercase letter "O" not a Zero, not lowercase. Which basically tells it not to change times of directories it doesn't have permissions to! The other option that would be suspect is "-t" which preserves times. I didn't want to mess with this as I thought times might be important to the delta function of rsync.
In the case of the Rsync Backup App - I had to modify 2 shell scripts that actually run the rsync. One to test connectivity and one to perform the backup. They are located in:
Code:
/raid0/data/module/Rsync_Backup/bin
and the files are "backup.sh" and "rsync_test.sh" You will need to fire up SSH and log in to the Thecus to edit these files - you can use vi or sometimes easier winscp (I also like filezilla for an SCP utility.) Both of these tasks are outside the scope of this increasingly lengthy post.
Inside these shell scripts, go down to the part that is actually invoking the rsync command, and edit the options to include the Uppercase "O" (not zero, not lowercase) it should look something like this after:
Code:
if [ "${model}" == "0" ];then
                                strExec="$rsync -8rltDvHO --log-file=\"$log_file\" --port=${port} --chmod=ugo=rwX --timeout=180 [bla... bla.. ] etc...
                        else
                                strExec="$rsync -8rltDvHO --log-file=\"$log_file\" --port=${port} --chmod=ugo=rwX --timeout=180 [bla... bla.. ] etc...
I have highlighted the only change you need to make (Uppercase "O" not zero, not lowercase) in Bold and underlined here: "-8rltDvHO"
Save the files and run the rsync and it should work. I have been running mine now on a daily scheduled backup for a couple months and it works perfectly!

Now for DataGuard, its going to be a little bit more tricky.
The files are located in:
Code:
/img/bin/dataguard/
they are also for some reason symlinked to another location: /app/bin/dataguard/
The interesting files there are probably: "remote_backup.sh" and "copy.sh" I would guess EVERY option set needs to be edited to include the Uppercase "O" (not zero, not lowercase).

The bigger problem is that these files and directories are all mounted as a read-only filesystem. Changing permissions is not allowed - even by root. I tried.
I found a forum that seems to have found a solution, but I don't have the time to test this. Perhaps others wanting to do similar tasks can provide guidance. You can find it here: http://stackoverflow.com/questions/21544...thout-sudo
Go down to the 1st answer and expand to see all comments. The last one says:
Code:
cp -a /img/www /srv; umount /img/www; mount --bind /srv/www /img/www (instead of /srv you can use any other place you like) – Brave Sir Robin Feb 4 '14 at 13:03
       
Thankyou! That worked :) – Shannon Hochkins Feb 4 '14 at 21:44

Let us know if it works for you!

I hope someone finds this useful even if dataguard turns out to be unfixable.
Cheers.
Reply
#3
Hey there, I realize its been almost a year since you posted. But, I only ran into your unanswered question while searching for help with a similar problem. I looked long and hard and found nothing but people with the same issue and no solutions. So I solved it myself.
I too tried Data Guard and had the same issue - although I was attempting to rsync my Thecus with a Nas4free rsync server. Same thing really, standard rsync implementation. The broken english error you receive is no help. I moved on to trying an rsync Thecus App called "Rsync Backup". From which I received a very similar broken english error. Unfortunately it doesn't look like this app is available for your platform - I am running an N5550 v2.05.12 - but I think the fix may still be applicable to Data Guard.
I found in the logs of my Nas4free backup target that the Thecus was attempting to modify times on directories which Nas4free did not allow. Tried modifying permissions, didn't help. SO, I decided to modify the Thecus' rsync code. I found that there is an rsync option:
Code:
-O (or --omit-dir-times)
This is an Uppercase letter "O" not a Zero, not lowercase. Which basically tells it not to change times of directories it doesn't have permissions to! The other option that would be suspect is "-t" which preserves times. I didn't want to mess with this as I thought times might be important to the delta function of rsync.
In the case of the Rsync Backup App - I had to modify 2 shell scripts that actually run the rsync. One to test connectivity and one to perform the backup. They are located in:
Code:
/raid0/data/module/Rsync_Backup/bin
and the files are "backup.sh" and "rsync_test.sh" You will need to fire up SSH and log in to the Thecus to edit these files - you can use vi or sometimes easier winscp (I also like filezilla for an SCP utility.) Both of these tasks are outside the scope of this increasingly lengthy post.
Inside these shell scripts, go down to the part that is actually invoking the rsync command, and edit the options to include the Uppercase "O" (not zero, not lowercase) it should look something like this after:
Code:
if [ "${model}" == "0" ];then
                                strExec="$rsync -8rltDvHO --log-file=\"$log_file\" --port=${port} --chmod=ugo=rwX --timeout=180 [bla... bla.. ] etc...
                        else
                                strExec="$rsync -8rltDvHO --log-file=\"$log_file\" --port=${port} --chmod=ugo=rwX --timeout=180 [bla... bla.. ] etc...
I have highlighted the only change you need to make (Uppercase "O" not zero, not lowercase) in Bold and underlined here: "-8rltDvHO"
Save the files and run the rsync and it should work. I have been running mine now on a daily scheduled backup for a couple months and it works perfectly!

Now for DataGuard, its going to be a little bit more tricky.
The files are located in:
Code:
/img/bin/dataguard/
they are also for some reason symlinked to another location: /app/bin/dataguard/
The interesting files there are probably: "remote_backup.sh" and "copy.sh" I would guess EVERY option set needs to be edited to include the Uppercase "O" (not zero, not lowercase).

The bigger problem is that these files and directories are all mounted as a read-only filesystem. Changing permissions is not allowed - even by root. I tried.
I found a forum that seems to have found a solution, but I don't have the time to test this. Perhaps others wanting to do similar tasks can provide guidance. You can find it here: http://stackoverflow.com/questions/21544...thout-sudo
Go down to the 1st answer and expand to see all comments. The last one says:
Code:
cp -a /img/www /srv; umount /img/www; mount --bind /srv/www /img/www (instead of /srv you can use any other place you like) – Brave Sir Robin Feb 4 '14 at 13:03
       
Thankyou! That worked :) – Shannon Hochkins Feb 4 '14 at 21:44

Let us know if it works for you!

I hope someone finds this useful even if dataguard turns out to be unfixable.
Cheers.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Data Guard] wbree 6 3,936 03-12-2015, 08:52 PM
Last Post: ladlasheikh
  n2560 & DATA GUARD mtogni 23 5,650 08-26-2014, 05:42 AM
Last Post: tobilux
  Data Guard: Task won't terminate, how to clear? realdragonluv 5 3,283 05-24-2014, 06:18 PM
Last Post: markison
  Data Guard. Or: How to sync USB data to the NAS tobilux 15 4,381 03-15-2014, 06:44 PM
Last Post: Qoolbox
  Data Guard (2.03.09.cdv) Connection timeout scottlightner 2 1,867 07-28-2013, 06:13 AM
Last Post: Qoolbox
  [Data Guard] 0 2,555 Less than 1 minute ago
Last Post:
  Data Guard: Task won't terminate, how to clear? 0 2,085 Less than 1 minute ago
Last Post:
  Data Guard (2.03.09.cdv) Connection timeout 0 1,192 Less than 1 minute ago
Last Post:
  [Data Guard] Problem Connecting to DeltaCopy Server 0 1,577 Less than 1 minute ago
Last Post:

Forum Jump:


Users browsing this thread: 1 Guest(s)