Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't shutdown, critical process is running
#1
I lost power the other day with a UPS and when I got everything back up and running the N4100 has been at 100% CPU utilization for 20 hours. The data is there, everything looks ok but it's super slow. How can I figure out what process is running that won't let me reboot it? I tried SSH but I guess this model does not have that on by default.
Reply
#2
Is it rebuilding the array ? In which case DON'T shut it down till it's done!

You can check the status with

cat /proc/mdstat

You'll get output something like this :

<!-- e --><a href="mailto:root@127.0.0.1">root@127.0.0.1</a><!-- e -->:~# cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
md1 : active raid5 sda2[0] sdd2[3] sdc2[2] sdb2[4]
5854396032 blocks super 1.0 level 5, 128k chunk, algorithm 2 [4/4] [UUUU]

md0 : active raid1 sdd1[3] sdc1[2] sdb1[1] sda1[0]
2047988 blocks super 1.0 [4/4] [UUUU]

unused devices: <none>


"md1" is the main RAID-5 set of disks in my machine.
N4200Pro with 4 * 2TB WD20EARS drives, upgraded to 4GB RAM.
Reply
#3
I said I don't have access to ssh. How do you get to the command line without it? And from the syslog no it's not rebuilding. The syslog shows nothing from the GUI interface.
Reply
#4
Doh sorry .. read that line then promptly forgot :-)

SSH module for N4100pro : <!-- m --><a class="postlink" href="http://www.fajo.de/main/en/thecus/modules/fajosshd">http://www.fajo.de/main/en/thecus/modules/fajosshd</a><!-- m -->
N4200Pro with 4 * 2TB WD20EARS drives, upgraded to 4GB RAM.
Reply
#5
strandedinnz Wrote:Doh sorry .. read that line then promptly forgot :-)

SSH module for N4100pro : <!-- m --><a class="postlink" href="http://www.fajo.de/main/en/thecus/modules/fajosshd">http://www.fajo.de/main/en/thecus/modules/fajosshd</a><!-- m -->
Won't that require a reboot to install?
Reply
#6
Nah, shouldn't do.
N4200Pro with 4 * 2TB WD20EARS drives, upgraded to 4GB RAM.
Reply
#7
I am trying to install the module but it's just sitting at file uploading prompt on the GUI interface. I have a feeling it's gonna wait for that mystery critical process to finish which has been running for over 24 hours now.
Reply
#8
Wow it just finished uploading and installing, with the CPU at 100% this thing is crawling. Trying to enable the module now, another long wait........
Reply
#9
It's not working. I enabled the module, the log shows that the service was started. I tried putty on port 1022 and get a connection refused error. I also tried port 22.
Reply
#10
Did you try port 10022 ?
N4200Pro with 4 * 2TB WD20EARS drives, upgraded to 4GB RAM.
Reply
#11
I had to modify the config for AddressFamily Any, it was commented out. Now a bigger issue, I have a login but I don't know the root password! It's not the same as GUI password?
Reply
#12
I added a user and made a password but the ssh is still not letting me past the password prompt. I have to assume the config file needs something else uncommented out. Here is my current config:

## (Multiple Port options are permitted.)
Port 22
#Port 10022

## Valid arguments are "any", "inet" (use IPv4 only) or "inet6" (use IPv6 only).
AddressFamily any

## Syntax:
## ListenAddress host|IPv4_addr|IPv6_addr
## ListenAddress host|IPv4_addr:port
## ListenAddress [host|IPv6_addr]:port
#ListenAddress 0.0.0.0
#ListenAddress ::

## Possible values are "1", "2" or '1,2'
Protocol 2

## Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 1024

## Logging
SyslogFacility AUTH
LogLevel INFO

## Authentication
#LoginGraceTime 2m
PermitRootLogin yes
#StrictModes yes
StrictModes no
#MaxAuthTries 6
#MaxSessions 10

#RSAAuthentication yes
PubkeyAuthentication yes

## For this to work you will also need host keys
## in /raid/data/module/FaJoSSHD/system/etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
## similar for protocol version 2
#HostbasedAuthentication no

## Change to yes if you don't trust ~/.ssh/known_hosts for
## RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no

## Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

## To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
PermitEmptyPasswords yes

## Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

#AllowTcpForwarding yes
AllowTcpForwarding no
#AllowAgentForwarding yes
AllowAgentForwarding no
#GatewayPorts no
#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
UseDNS no
#MaxStartups 10
#PermitTunnel no
#ChrootDirectory none

# no default banner path
#Banner none


## Example of overriding settings on a per-user basis
#Match User anoncvs
# X11Forwarding no
# AllowTcpForwarding no
# ForceCommand cvs server
Reply
#13
The root password should be the same as the admin password you for the GUI .. at least that's how I read the instructions.
N4200Pro with 4 * 2TB WD20EARS drives, upgraded to 4GB RAM.
Reply
#14
It's not or something with the SSH config file was not right. What is odd about that SSH package is they don't have any default values setup for a simple login. I was never able to login.

About 30 hours in the syslog got poked that the RAID is now healthy, so there must have been some sort of corruption from the power failure that was not logged in the syslog.
Reply
#15
Hello gquiring,

some notes on the posted Wink

gquiring Wrote:It's not or something with the SSH config file was not right. What is odd about that SSH package is they don't have any default values setup for a simple login. I was never able to login.

The only user that ill ever be able to log in to the NAS via SSH will be "root" - this is because no other users will ever get a valid shell set. The password to be used is the same as you use for the log in to the Web UI. If logging in using the GUI's admin password you will have to re-enable the module once to make sure the password gets updated properly.

gquiring Wrote:I had to modify the config for AddressFamily Any, it was commented out. Now a bigger issue, I have a login but I don't know the root password! It's not the same as GUI password?

There is no no need to uncomment it as the commented out values are default values, so, "AddressFamily any" is set per default. Looks like you simply used the wrong port (1022 instead of 10022).

For security you should also revert back to the default setting of "no" for PermitEmptyPasswords.

/Falk
Further information und module downloads at FaJo.de

I decided to finally stop module development and maintenance. Existing modules are still available for download for now.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Can't shutdown, critical process is running 0 1,447 Less than 1 minute ago
Last Post:

Forum Jump:


Users browsing this thread: 1 Guest(s)