Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[ Apache x86 & x64 & PPC (PHP 5.6.2)] [2.2.29.1] Web Server
#1
[Image: httpd_logo_wide_new.png]

Source : [url]http://httpd.apache.org/[/url]

WARNING : I DECIDED RELEASE THE 2.2.X BRANCH DUE TO SOME INCOMPATIBILITIES WITH THE 2.4.X RELEASED PREVIOUSLY
IF YOU USE THIS MODULE THANKS TO UNINSTALL ALL PREVIOUS 2.4.X VERSION (YOUR HTDOCS IS SAFE)
THANKSFOR YOUR UNDERSTANDING (PLEASE NOTE THAT ALL ACUAL WEB APPLICATIONS WILL BE PORTED ON THIS RELEASE ONE BY ONE)



Download :

x64 version : [url]http://www.positiv-it.fr/thecus/download....0_x64.rar[/url]
x86 Version : [url]http://www.positiv-it.fr/thecus/download....0_x86.rar[/url]

[ Previous Release ] [PHP 5.5.10]

x64 version : [url]http://www.positiv-it.fr/thecus/download....1_x64.rar[/url]
x86 Version : [url]http://www.positiv-it.fr/thecus/download....1_x86.rar[/url]
PPC Version : [url]http://www.positiv-it.fr/thecus/download....1_PPC.rar[/url] (Firmware built_734 minimum required)

[ Previous Release ] [ PHP 5.5.11] [ OpenSSL upgraded to fix HeartBleed issue only impact x86 and ppc version ]

x64 version : [url]http://www.positiv-it.fr/thecus/download....0_x64.rar[/url]
x86 Version : [url]http://www.positiv-it.fr/thecus/download....1_x86.rar[/url]
PPC Version : [url]http://www.positiv-it.fr/thecus/download....1_PPC.rar[/url] (Firmware built_734 minimum required)

[ Previous Release ] [ PHP 5.5.13] [ Upgraded to PHP 5.5.13 (added gmp pspell extension + smartmonctl/zip/par2cmdline/libwxml2/tnef binaries ]

x64 version : [url]http://www.positiv-it.fr/thecus/download....2_x64.rar[/url]
x86 Version : [url]http://www.positiv-it.fr/thecus/download....2_x86.rar[/url]
PPC Version : [url]http://www.positiv-it.fr/thecus/download....2_PPC.rar[/url]

[ Previous Release ] [ PHP 5.6.0] [ Upgraded to PHP 5.6.0 and Apache 2.2.29 (added tmux/lshw/msmtp/ssmtp/xsp (Intel only) - updated OpenSSL 1.0.1i ]

x64 version : [url]http://www.positiv-it.fr/thecus/download....0_x64.rar[/url]
x86 Version : [url]http://www.positiv-it.fr/thecus/download....0_x86.rar[/url]
PPC Version : [url]http://www.positiv-it.fr/thecus/download....0_PPC.rar[/url]

[ Actual Release ] [ PHP 5.6.2] [ Upgraded to PHP 5.6.2 (added Some CPAN, Mod_Security2 - updated to OpenSSL 1.0.1j ]

x64 version : [url]http://www.positiv-it.fr/thecus/download....1_x64.rar[/url]
x86 Version OS5: [url]http://www.positiv-it.fr/thecus/download...86_OS5.rar[/url]
x86 Version OS6: [url]http://www.positiv-it.fr/thecus/download...86_OS6.rar[/url]
PPC Version : [url]http://www.positiv-it.fr/thecus/download....1_PPC.rar[/url]

NOTE :

Create /raid/data/htdocs on first install for your website (just have to create a share called htdocs)
Listen on port 88 (448 in https)
Manage httpd.conf and PHP.ini within the Thecus Webui

Avaiable module added and extension :

Modules :

Code:
Mod_Perl (2.08)
Mod_Python (3.5.0)
Mod_Mono (2.10) (not include in PPC Version)
Mod_DAV_SVN (1.8.8)
Mod_authz_svn (1.8.8)

Extension :

Code:
APC (APCU)
MEMCACHE
ZIP
RAR
IMAGICK
XATTR
MONGODB
timezoned
XML_RPC
pecl_http
krb5
radius
mailparse

Binaries :

Code:
Apache 2.2.26
php 5.5.10
Imagemagic
avconv (not include in PPC Version, replaced by ffmpeg 2.1.4)
mono 3.2.8 (not include in PPC Version)
NodeJS 0.10.26 (x64 version only)
Perl 5.18.1
Python 2.7.6
Ruby 2.0.0
RRDTOOL 1.4.7
subversion 1.8.5
Midnight Commander 4.8.11
memcache 1.4.17

About :

What is the Apache HTTP Server Project?

The Apache HTTP Server Project is a collaborative software development effort aimed at creating a robust, commercial-grade, featureful, and freely-available source code implementation of an HTTP (Web) server. The project is jointly managed by a group of volunteers located around the world, using the Internet and the Web to communicate, plan, and develop the server and its related documentation. This project is part of the Apache Software Foundation. In addition, hundreds of users have contributed ideas, code, and documentation to the project. This file is intended to briefly describe the history of the Apache HTTP Server and recognize the many contributors.
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#2
Hi Stephane,

Great you release a undepanded version of the apache server.

Will there more modules inside in next updates ?

You know i use the rewrite mod alot for all my websites.
So it would be nice if that is inside.

And don't we need modbase or php53 anymore in these versions ?

Lot of quistions but you know i use apache really alot.

PS offrecord quistion.. you plan to go to cebit this year ??

Greetings from holland
Thecus N5200xxx with 3gb internal mem and 3 times 1.5 tb
Reply
#3
Hello,

Yes mod_rewrite is embedded (enable by default) all standard module are inside too, all fajo extension are embedded in this release and more ...

All the actual module will have the 2.2.x branch version (it is just an httpd.conf modification)

unfortunately Thecus will not be at Cebit this year Sad


Have fun,
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#4
published my phpinfo page

PHP 5.5.9 phpinfo ()

http://positiv-it.fr/thecus/IMG/apache2/phpinfo().htm
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#5
not swinging from App Center.
Reply
#6
xsacha Wrote:not swinging from App Center.

Let me finish the x86 version first Wink
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#7
x86 version added (nodejs not integrated in this version due to cross compilation issue)
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#8
Hi

does it need any more modules to install Apache_2.2.26.0_x86.rar?
im receive error message that it is not possible upload the module.

To install owncloude 6.02 is it any other modules needed then Apache 2.2.26.0?

Sincerely, / Chali
Reply
#9
you have to unrar the file first.

no module dependency required
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#10
I did, but apparently I need to also uninstall owncloud to install this apache.
Now I have installed the new apache and Ownclude 6.0.2 and started them, but when I try to go to the web interface I only get, (Unable to connect)
that message, I get at both Apache and owncloude.

The modules I have installed are: Apache 2.2.26.0 (x86) Owncloude 6.0.2 (x86)
and my wingftp server x86. (WingftP works)

Do you have any idea what could be wrong?

Regards / Chali
Reply
#11
Uninstall previous Ownlcoud and reinstall

you have to use the OwnCloud Apache 2.2.x version (there are two version inside the Ownlcoud 6.0.2 achive)

Wink
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#12
Hello again

This is how I installed ​​it?
you do not need Fajo PHP53 and Fajo ModeBase1 anymore? (for owncloude to work)

/ Sincerely Chali
Reply
#13
no it is not necessary

when you click on Apache 2.2.26, do you see on port 88 the It Works message ?
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#14
Hello again

Finally I got it all working thank you

/Chali
Reply
#15
Great Wink
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Apache (PHP 5.6.22)][2.2.29.2] Web Server outkastm 11 4,926 06-17-2017, 05:32 PM
Last Post: outkastm
  [ Apache 2.4.10 (PHP 5.6.0) x86 & x64 ] Web Server Qoolbox 143 42,936 01-23-2017, 07:51 AM
Last Post: sint
  [Apache x86] [2.4.4.2] HTTP Server Qoolbox 94 31,150 01-03-2014, 05:37 AM
Last Post: scavenger
  [Apache x64] [2.4.4.2] HTTP Server Qoolbox 31 11,750 11-21-2013, 06:07 PM
Last Post: xsacha
  [ Apache Web Server x86 & x64 ] [ 2.4.6 ] Web Server Qoolbox 35 10,873 10-28-2013, 09:31 PM
Last Post: drukman
  [Apache x86][2.4.2.2] HTTP server alain.roger 1 1,073 01-26-2013, 06:10 PM
Last Post: alain.roger
  [ Apache Tomcat 7 x86 & x64 ] [ 7.0.33 ] Http Server Qoolbox 5 3,643 12-10-2012, 04:59 PM
Last Post: Qoolbox
  [ Apache Tomcat 7 x86 & x64 ] [ 7.0.33 ] Http Server 0 2,634 Less than 1 minute ago
Last Post:
  [Apache x86][2.4.2.2] HTTP server 0 669 Less than 1 minute ago
Last Post:
  [ Apache Web Server x86 & x64 ] [ 2.4.6 ] Web Server 0 5,133 Less than 1 minute ago
Last Post:
  [ Apache 2.4.10 (PHP 5.6.0) x86 & x64 ] Web Server 0 24,290 Less than 1 minute ago
Last Post:
  [ Apache x86 & x64 & PPC (PHP 5.6.2)] [2.2.29.1] Web Server 0 25,669 Less than 1 minute ago
Last Post:

Forum Jump:


Users browsing this thread: 1 Guest(s)