Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Firmware update for the N4100PRO
#1
Hi everyone,

Firmware 5.03.01 is available online for the N4100PRO.

Firmware 5.03.01
How to upgrade the N4100PRO from firmware v3 to v5
1) Please refer to the Release Note for N4100PRO.
2) Unzip the Firmware package zip file, then follow the upgrade procedure of README.txt to upgrade from v3 to v5.

[New Features/Changes]
1) Add System status & online user list.
2) Add Virus scan module support.
3) Add Czech language.

To download the update, please go to: <!-- m --><a class="postlink" href="http://www.thecus.com/sp_download.php">http://www.thecus.com/sp_download.php</a><!-- m -->
For the release notes on how to up-date to V5, please go to: <!-- m --><a class="postlink" href="http://www.thecus.com/Downloads/FW/N4100PRO/N4100PRO_FWRN_5.03.01.pdf">http://www.thecus.com/Downloads/FW/N410 ... .03.01.pdf</a><!-- m -->
Jonathan

Forum Manager / Responsable Forum
Reply
#2
Online user list works (checked SMB and NFS), but SMB user seem to revert to "root" after closing connection instead of disappearing, after being correct during the connection.
Network monitoring doesn't work anymore (speed is 0), after it worked for some time after fresh restart.
Global IPv6 address is correctly assigned via RA, and device responds to IPv6 ping (NICE!), but no support for services yet.
N4100PRO
Reply
#3
Hi,

Thank you for your comments!

Quote:Online user list works (checked SMB and NFS), but SMB user seem to revert to "root" after closing connection instead of disappearing, after being correct during the connection.
Please provide more information about this so we can replicate the condition. What is your procedure to come up with this result?

Quote:Network monitoring doesn't work anymore (speed is 0), after it worked for some time after fresh restart.
We seemed to have a bug here. Good call! We'll provide a fix for this as soon as we can.

Quote:Global IPv6 address is correctly assigned via RA, and device responds to IPv6 ping (NICE!), but no support for services yet.
Basically the IPv6 is only supported on 64bit firmware model (ie: N2800 /N4800 /N5550, etc.), so that is why it is not fully functional.
N4100PRO does not support this service.
Jonathan

Forum Manager / Responsable Forum
Reply
#4
Does this new firmware include the fixes for the share management and fan speed issues that were addressed in beta firmware releases? I don't see any mention of them in the release notes.
Reply
#5
Hi Jonathan,
Here the details:

Test setup: N4100Pro, raid5 with 4 x 1.5 TB disks (Seagate), SMB name N4100pro, public shared folder "Video" with some movies on it. Computer uses Windows7 64bit.

1. Open web page on NAS and go to System Monitor.
2. Open Windows Explorer, open NAS Folder (\\N4100pro\Video) and start browsing.
In lower left pane, a Samba(1) line will appear, on expanding, it shows IP, user "nobody", folder "Video" (which is correct).
3. Start watching a video. User stays unchanged.
4. Close video player (without closing explorer) and wait about 1 minute and watch system monitor.
User name changes from "nobody" to "root" (this is wrong).
4. Restart movie play from explorer - user changes back to "nobody" (correct).
5. Close video player again and wait about 1 minute and watch system monitor.
User name changes again from "nobody" to "root" (this is wrong).
6. Close explorer or do not touch - after 30 sec user disappears from list (correct).

The same behavior can be seen if logged in to private folders with specific user (it turns from user to root after 1 minute of inactivity but with open explorer).

Marius
N4100PRO
Reply
#6
markm Wrote:Does this new firmware include the fixes for the share management and fan speed issues that were addressed in beta firmware releases? I don't see any mention of them in the release notes.

Share management, yes.

Fan - I don't believe so. I'm at 35 degrees and 1400 RPM.
Reply
#7
markm Wrote:Does this new firmware include the fixes for the share management and fan speed issues that were addressed in beta firmware releases? I don't see any mention of them in the release notes.

Share management, yes.

Fan - I don't believe so. I'm at 35 degrees and 1400 RPM.
Reply
#8
Still same issue whit the fan speed. The Nas runs fine for up to 6-7 hours then the fan speed stops. After a reboot it is all well for another 6-7 hours. :x
Reply
#9
Still same issue whit the fan speed. The Nas runs fine for up to 6-7 hours then the fan speed stops. After a reboot it is all well for another 6-7 hours. :x
Reply
#10
Since the firmware upgrade to version 5.03.01 I cannot use my N4100PRO anymore.

I can read every file but writing does not work for larger files (videos). Smaller files (MP3) are working occasionally.

I tried all network and SMB settings but nothing helps.

It is unbelievable that Thecus does not delivering a new firmware upgrade since July this year.

Does anybody have a clue what I can try to solve my problem?
Reply
#11
Hello,

i had the same problem with my N4100PRO. I opened a ticket with support and after trying numerous items (changing network connections, disabling jumbo frame) the end result was they cuold not replicate it and the solution was to downgrade to FW V5.01.04. After downgrading the firmware everything worked again.
Reply
#12
Thanks - since downgrading to version 5.01.04 it works again.

What a shame for Thecus! Never again - I'm happy with my two Drobos.
Reply
#13
Thanks - since downgrading to version 5.01.04 it works again.

What a shame for Thecus! Never again - I'm happy with my two Drobos.
Reply
#14
Has anyone had a good experience upgrading to this firmware? I'm running v5.01.05 now with only one issue. If I turn on SAMBA recycle bin, I have to periodically manually delete items from the .recycle folders on all shares.

I saw a thread that indicates that v5.02.0 or later has a feature where you can specific how long items should stay in the .recycle folder before being automatically purged.

I also saw lots of postings from people who tried v5.02.02 and later and ran into many other problems. I could happily run my current v5.01.05 and just manually purge recycled items from time to time, but a piece of me wants to be "current" for no reason other than "current" sounds better than "old."

I'm looking for advice? Should I take the plung and upgrade to a newer firmware build?
Reply
#15
Has anyone had a good experience upgrading to this firmware? I'm running v5.01.05 now with only one issue. If I turn on SAMBA recycle bin, I have to periodically manually delete items from the .recycle folders on all shares.

I saw a thread that indicates that v5.02.0 or later has a feature where you can specific how long items should stay in the .recycle folder before being automatically purged.

I also saw lots of postings from people who tried v5.02.02 and later and ran into many other problems. I could happily run my current v5.01.05 and just manually purge recycled items from time to time, but a piece of me wants to be "current" for no reason other than "current" sounds better than "old."

I'm looking for advice? Should I take the plung and upgrade to a newer firmware build?
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  N4100Pro firmware update from V3 to V5 Thecus - Jonathan 21 11,283 05-14-2015, 04:50 PM
Last Post: Thecus - Bertha
  Unable To Access N4100pro After Firmware Update Charliebear 3 1,650 11-28-2011, 10:23 PM
Last Post: PeterVV
  N4100Pro firmware update from V3 to V5 0 5,774 Less than 1 minute ago
Last Post:

Forum Jump:


Users browsing this thread: 1 Guest(s)