Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thecus official SDK - 6/17/2011 Version
#46
:roll:

desperating to have a clean Toolchain... and i not releave the others problem...

/usr/local/ToolChain/i686-nptl-linux-gnu_1.00/lib/pkgconfig

Code:
prefix=/home/kevin/x-tools/i686-nptl-linux-gnu
exec_prefix=${prefix}
libdir=${exec_prefix}/lib
includedir=${prefix}/include

Name: libgcj
Description: libgcj
Version: 4.3.2
Libs: -L${libdir} -lgcj
Cflags: -I${includedir}

also in /usr/local/ToolChain/rootfs/lib

a lot of symlink with missing link

for example :

Quote:libblkid.so
missing symlink should point on
Quote:/home/luke/ToolChain/x86_32/rootfs/lib/libblkid.so.1
who is luke ??? lol

and there is a lot like this...

PLEASE THECUS UPDATE THE TOOLCHAIN MANY MANY ERRORS.. i use the x86 one... :oops:
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#47
:roll:

desperating to have a clean Toolchain... and i not releave the others problem...

/usr/local/ToolChain/i686-nptl-linux-gnu_1.00/lib/pkgconfig

Code:
prefix=/home/kevin/x-tools/i686-nptl-linux-gnu
exec_prefix=${prefix}
libdir=${exec_prefix}/lib
includedir=${prefix}/include

Name: libgcj
Description: libgcj
Version: 4.3.2
Libs: -L${libdir} -lgcj
Cflags: -I${includedir}

also in /usr/local/ToolChain/rootfs/lib

a lot of symlink with missing link

for example :

Quote:libblkid.so
missing symlink should point on
Quote:/home/luke/ToolChain/x86_32/rootfs/lib/libblkid.so.1
who is luke ??? lol

and there is a lot like this...

PLEASE THECUS UPDATE THE TOOLCHAIN MANY MANY ERRORS.. i use the x86 one... :oops:
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#48
May be it is time to thecus to update the sdk with separate toolchains for each nas release

Toolchains with bug fixed (see previous threads)
Toolchain for Evo models
And how to manage local display on x64 for developper


Thans for any update
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#49
May be it is time to thecus to update the sdk with separate toolchains for each nas release

Toolchains with bug fixed (see previous threads)
Toolchain for Evo models
And how to manage local display on x64 for developper


Thans for any update
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#50
New error in SDK

trying to compile PPL


Code:
/bin/grep: /home/kevin/x-tools/i686-nptl-linux-gnu/i686-nptl-linux-gnu/lib/libstdc++.la: No such file or directory
/bin/sed: can't read /home/kevin/x-tools/i686-nptl-linux-gnu/i686-nptl-linux-gnu/lib/libstdc++.la: No such file or directory
libtool: link: `/home/kevin/x-tools/i686-nptl-linux-gnu/i686-nptl-linux-gnu/lib/libstdc++.la' is not a valid libtool archive
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#51
Published my own ToolChain Based on Debian x64


http://forum.thecus.com/viewtopic.php?f=70&t=6661
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#52
Published my own ToolChain Based on Debian x64


http://forum.thecus.com/viewtopic.php?f=70&t=6661
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#53
Hi

Which VMDK should I use for the N2200EVO, according to the spec sheet for the N2200EVO, it's a covium manufactured processor, covium seem to have various families of processor, so knowing it's covium doesn't appear to help. The Intel VMDK doesn't seem appropriate (N2200xxx) neither does the VMDK for the N2200plus.

Thanks

Bullfrog(2)
Reply
#54
regarding Thecus info you have to ake the n2220plus SDK

Code:
catagory-1
    1U4200XXX (F/W 5.00.0x and above)
    1U4600 (F/W 5.00.0x and above)
    N2200XXX (F/W 5.00.0x and above)
    N3200XXX (F/W 5.00.0x and above)
    N4200 (F/W 5.00.0x and above)
    N4200PRO  (F/W 5.00.0x and above)
    N4200Eco (F/W 5.00.0x and above)
    N5200XXX (F/W 5.00.0x and above)
    N5500 (F/W 5.00.0x and above)
    N7700PRO (F/W 5.00.0x and above)
    N7700Plus (F/W 5.00.0x and above)
    N8200XXX (F/W 5.00.0x and above)
    N8800PRO (F/W 5.00.0x and above)
    N8800Plus (F/W 5.00.0x and above)

catagory-2
    N16000/N16000V/N16000PRO
    N12000/N12000V/N12000PRO
    N8900/N8900V
    N6850/N8850/N10850
    N2800/N4800/N5550

catagory-3
    N2200Plus
    N4100EVO/N2200EVO
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#55
Aha

Spot on.

Thank you.

Bullfrog(2)
Reply
#56
hope soon watch your releases in the forum Wink
Stéphane Guérithault

In a world without walls and fences, who needs Windows and Gates

PayPal Donation: https://www.paypal.me/qoolbox

My apps

##########################################################################

rolling now for competitor, i do not support anymore Thecus apllications due to lack of time

##########################################################################


voyance - Sophrologue Hypnothérapeute Essonne 
Reply
#57
Hi, I have a N5810 NAS, I want compile own module. Which SDK I need use ?
N5810 OS7.0
Reply
#58
Hi, I have a N5810 NAS, I want compile own module. Which SDK I need use ?
N5810 OS7.0
Reply
#59
And for information. I use OS7 actually and don`t plan downgrade to OS5. Rather compile own module with application which I need ;P
N5810 OS7.0
Reply
#60
And for information. I use OS7 actually and don`t plan downgrade to OS5. Rather compile own module with application which I need ;P
N5810 OS7.0
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [REQUEST] Newer version Subsonic for Thecus N2310 saken 2 1,377 03-28-2017, 06:09 AM
Last Post: outkastm
  [XBMC][version 13 gotham] on thecus N5550 ptran1234 3 1,561 09-02-2014, 12:10 PM
Last Post: John Tsai
  Thecus SDK (beta version) is available!! Thecus - Kevin 3 2,649 06-01-2011, 09:38 PM
Last Post: fajo
  [XBMC][version 13 gotham] on thecus N5550 0 843 Less than 1 minute ago
Last Post:

Forum Jump:


Users browsing this thread: 1 Guest(s)