Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Twonky server not accessible through port :9000
#1
Hi,

Please help. My Twonky server worked well for a while and then all of a sudden stopped. I tried to access it through the web interface but it keeps saying I cannot access the page. I have a static IP address and cannot access it.

It is showing as an activated app in my app page on my dashboard but when I click on 'enter app page' I get a message that the page is not reachable.

Is there ANY way I get access the server to maybe change the port to another port or if there's a way for me to access the page in any other way?

I have installed and uninstalled the app as well but after 30 days it asks me for my registration key (I have a registration key) but I cannot access the port to enter the registration key?

Would appreciate ANY help to get this sorted.

Thanks - see info below and screenshots attached.

I am running OS7 and this is the firmware version of my Thecus:
Thecus N5810 PRO
Firmware: 3.02.00.4

   
   
Reply
#2
to change the port edit this file
/raid/data//module/Twonkymedia/bin/run/twonkyserver.ini
look for this line and your desire port there, as example 8003
Code:
# Port of the http server
httpport=9003

Then restart the module
-----------------------------------------------------------------------------------------------------
[Image: linkedinbutton.jpg]
Download modules from my forum https://pirinel.ro
Reply
#3
(07-16-2017, 02:52 AM)outkastm Wrote: to change the port edit this file
/raid/data//module/Twonkymedia/bin/run/twonkyserver.ini
look for this line and your desire port there, as example 8003
Code:
# Port of the http server
httpport=9003

Then restart the module

Thank you - I cannot seem to navigate there using my static IP address.

Can you please let me know how to navigate to this folder - I am using a Mac.

Would appreciate your help.
Reply
#4
i would assume you need to use a ftp client and use the root login,with a user login u wont have permission to edit this file.
alternatively you could just ssh and use vi(editor).
if you have never used it before google vi commands for how to use it.
Reply
#5
(07-16-2017, 07:17 AM)Blackbear199 Wrote: i would assume you need to use a ftp client and use the root login,with a user login u wont have permission to edit this file.
alternatively you could  just ssh and use vi(editor).
if you have never used it before google vi commands for how to use it.

Thanks - eek - I have no idea what I am doing and do not know how to access ssh, how the commands work and cannot seem to get to the folder/file to figure out how to change it. Googled it but one seems to have to know some of the basics and the language which I can't seem to understand. 

It's not as easy if you've never done it before and don't know the language used.

If there's anyone who could help tell me what to type and where to go I would appreciate it... Confused
Reply
#6
So, managed to use Cyberduck, logged in via SFTP to be able to use ssh 'root' as login. 

Logged in, browsed to Twonky file, went in to 'edit' .ini file (as per few posts above) and saw that the actual http port was something completely different:

The http port was set at http//[yourip]:10243

Not sure if this will help others - did not change the port, kept it there but was able to activate Twonky again and will use this port to access the menu/settings.

Thanks again, seem to be sorted...
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Twonky Media Server 7.0.8 Troogroove 3 4,833 05-20-2013, 12:22 AM
Last Post: Qoolbox
  Twonky Server Disconnecting - Solution OverLord 6 3,146 03-29-2013, 09:15 AM
Last Post: OverLord
  Twonky Media Server 6.0.34 Please help! mtogni 1 1,785 04-02-2012, 10:18 PM
Last Post: mtogni

Forum Jump:


Users browsing this thread: 1 Guest(s)