Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
N4810 usb printer
i dont see any section for this model so where is one suppost to ask questions?

new n4810
bios V1.4

when i connect my usb printer(brother dcp-7020) it shows it detected as it shoud as a usb-printer but the name and model is blank.
if i select the name(usb-printer) and click on edit i get "error 500 unexpected server error"

so i went back to firmware and i could get the menu to come up when i selected edit and change the printer name from the default of usb-printer.

i then updated again to and it kept this name change but if i select edit i get the same result as i first did.

so it doesnt display the name or model for this printer,i know its old but it suits my needs.

so i next added it on my pc's

on windows i used the http://localhost:631/printers and after setting it up it seems to work fine.

on my linux pc which you can add a printer the same way when ever i try to print anything it just spits out blank pages until the trays empty.

i originally had the printer on my windows pc(shared) and it worked fine printing from my linux pc.

can someone look into this please.
Dear Sir,

Would you please try on V3.02.01.k401?
(07-10-2017, 12:17 PM)Thecus - Yvon Wrote: Dear Sir,

Would you please try on V3.02.01.k401?

downgraded to that firmware and its same as it was with

cannot edit printer name(500 internal server error when I click on edit) and no manufacturer or model number showing.
NOTE: my screenshot shows DCP-7020 as printer name.this was done with firmware as I said in above post.

windows - prints fine
Linux - blank pages until it empties tray

[Image: 4j9r8i.png]
Dear Sir,

1. Please try on latest V3.02.02.k401:
2. Once new V3..02.02.k401 without help, please submit ticket from let our staff check for you.
already have tried it and its the same results.
i have a dell 968 printer also that i dont use anymore,as a test i connected it and it did detect the manufacturer and model correctly.
but when i click on the edit button i still get the "500:internal server error".
i guess i'll open a ticket.
i dont know what firmware update this was fixed in as i had my printer connected to my pc and was sharing it that way.
i tried few days ago connecting it back to my nas running latest beta firmware(
i have no issues at all now printing via a windows or linux pc.
it still show no manufacturer and model name for my printer(brother dcp-7020) but i was able to edit the name and the "500:Internal Server Error" doesnt appear anymore.
i think this is because its a pretty old printer(approx 10 yrs).
other than that as i said everything seems to be working fine.

Possibly Related Threads...
Thread Author Replies Views Last Post
  N4810 memory Blackbear199 10 1,684 07-21-2017, 10:03 PM
Last Post: Blackbear199

Forum Jump:

Users browsing this thread: 1 Guest(s)