Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
N4310 - clueless
#1
Hi,

I've been able to set up the N4310 in our home network. With a PC that is not in the same network I want to establish a NFS-connection. I have NFS enabled, but all attempts so far to connect the PC to the NAS failed. I get "no route to host" when I try a mount, which seems the correct way. I'm not sure if I entered the NAS-ID correctly. I used
Code:
NASName.thecuslink.com:/home/username
(replace "NASName" and "username" with the appropriate strings). But maybe there's another problem. I'm just quite clueless as I have never before tried to do that. Unfortunately, the manuals are in rather crude English and hard to understand. Any help will be aprreciated.

Martin
Reply
#2
Almost two days have passed with no reply. That's sad. I have continued to search solutions, with no luck. The only available guides seem to be for connections within a single network, not via the internet. That is bad. I guess I shouldn't have bought a Thecus. I'm seriously considering returning it to the vendor and buying a Synology instead, even though it is more expensive. But if I can't use it, there's no point in having it.
Reply
#3
Well, before Thecus reply i can give you my opininon.
NFS over WAN is not a good solution. I don't know if can be implemented, and is less secure anyway. Did you forward the needed ports on your router ?
http://linux.goeszen.com/nfs-over-the-internet.html
For what exactly do you need to access the NAS over WAN ? Maybe i can propose you another solution
-----------------------------------------------------------------------------------------------------
[Image: linkedinbutton.jpg]
Download modules from my forum pirinel.ro
Reply
#4
(05-17-2017, 06:22 PM)outkastm Wrote: Well, before Thecus reply i can give you my opininon.
NFS over WAN is not a good solution. I don't know if can be implemented, and is less secure anyway. Did you forward the needed ports on your router ?
http://linux.goeszen.com/nfs-over-the-internet.html
For what exactly do you need to access the NAS over WAN ? Maybe i can propose you another solution
I have two networks within the house, which need to be separated, and the NAS is only in one, but I need to connect to it from the other network. That's the reason why. And then I would also sometimes connect from a longer distance (cloud services kind of thing...)
I have also tried WebDAV, but it doesn't work either. I probably do something wrong, but have no clue what.
Reply
#5
Well, you have to explain your network configuration then. How did you connect the 2 networks to internet ? Are you able at least to access the NAS WebGUI ?
-----------------------------------------------------------------------------------------------------
[Image: linkedinbutton.jpg]
Download modules from my forum pirinel.ro
Reply
#6
(05-17-2017, 10:23 PM)outkastm Wrote: Well, you have to explain your network configuration then. How did you connect the 2 networks to internet ? Are you able at least to access the NAS WebGUI ?
Yes, that's no problem. I use the thecuslink.com address. The connection to the Internet is via routers - two different providers, two different routers. The NAS is connected to the Fritz!Box, I am connected to a TP-Link Archer VR2600v.

One note: I will be away for two days. I try to reply if Internet is available at the place where I go. But it may be that I can only take it up again on Saturday.
Reply
#7
Ok, I'm back. Any more thoughts on how to get to the NAS via Internet?
Reply
#8
You could securely bridge the two LANs by using something like Ubiquiti's EdgeX router (not that expensive) to connect them for local use.

For WAN/cloud connections, I you might be better off with other solutions. Are you running Linux or Windows on the NFS clients? What about using a secure FTP server? There's a CrushFTP module available for ThecusOS; at $40 for a home license, it's affordable.
Thecus N5550 (CPU: D2550 @ 1.86GHz, BIOS: 2.05.14.5.cdv X64)
Disks: 5 x 3TB Seagate NAS-class; 2 x 3TB-RAID1 plus Hot Spare
Memory: 8125 MB (2 x 4 GB Corsair 204-Pin DDR3 SO-DIMM 1333)
Apps: Too many to count....
Reply
#9
(05-21-2017, 09:58 PM)ThaumaTechnician Wrote: You could securely bridge the two LANs by using something like Ubiquiti's EdgeX router (not that expensive) to connect them for local use.  

I could, but that doesn't solve all problems, and it's really not what I want to do. The two LANs need to be separated for various reasons.


(05-21-2017, 09:58 PM)ThaumaTechnician Wrote: For WAN/cloud connections, I you might be better off with other solutions.  Are you running Linux or Windows on the NFS clients?  What about using a secure FTP server?  There's a CrushFTP module available for ThecusOS; at $40 for a home license, it's affordable.
I'm running Linux (Manjaro). I want to include the shared folder(s) into the filesystem on the client, so it's not viable to use FTP. I want to be able to access the files directly from the NAS, being able to open them directly and so on. 

I've read a lot and it seems to me that the right port isn't open for nfs. I tried non-standard ports, but I always get the
Code:
no route to host
message. I can connect via ssh, and sshfs would be fine, but I can use that only as root, as it seems, and I don't want to do that. I want the users whom I have added to the NAS to be able to access their respective shared folders on the NAS from their various locations.

From my understanding, the command
Code:
sudo mount -t nfs4 MyNAS.thecuslink.com:/MyName  /home/myname/NAS
should work. But it doesn't.
Reply
#10
you can use ssh with other users.
Use FaJoSSH module and edit the passwd file allowing user to connect by ssh
-----------------------------------------------------------------------------------------------------
[Image: linkedinbutton.jpg]
Download modules from my forum pirinel.ro
Reply
#11
Is port 2049 on your Fritz!Box forwarded to your NFS server?

Have you tested it from within your server's LAN? It would be worth trying this, so you can divide and conquer the problem.
Thecus N5550 (CPU: D2550 @ 1.86GHz, BIOS: 2.05.14.5.cdv X64)
Disks: 5 x 3TB Seagate NAS-class; 2 x 3TB-RAID1 plus Hot Spare
Memory: 8125 MB (2 x 4 GB Corsair 204-Pin DDR3 SO-DIMM 1333)
Apps: Too many to count....
Reply
#12
What do I have to change in passwd? Somehow the FajoSSH-docs are very rudimentary.
Reply
#13
FaJoSSHD is actually OpenSSH, so you can look on the docs for that. https://www.openssh.com
in /etc/passwd file, for the user you want to give access change the end of the line from :/dev/null to :/bin/bash.
FaJoSSH is setup default to work on port 10022. If you want to use it on port 22, stop SSH service from Thecus WebUI, change the port in FaJoSSHD config file and restart the module
-----------------------------------------------------------------------------------------------------
[Image: linkedinbutton.jpg]
Download modules from my forum pirinel.ro
Reply
#14
(05-22-2017, 04:29 AM)ThaumaTechnician Wrote: Is port 2049 on your Fritz!Box forwarded to your NFS server?


Yes.

(05-22-2017, 04:29 AM)ThaumaTechnician Wrote: Have you tested it from within your server's LAN?  It would be worth trying this, so you can divide and conquer the problem.

I just did that, however with sshfs. There I seem to be able to log in, but I get the response "no such file or directory". I used this command:
Code:
sshfs <username>@IP-NAS:<Port>/<username> /home/<myname>/NAS
I'm asked for the password, and other than trying from outside that network, where it just repeats three times asking the password, it appearently accepts the password but replies "<username>@IP-NAS:<Port>/<username> no such file or directory". I also tried
Code:
sshfs <username>@IP-NAS:<Port>/raid0/data/<username> /home/<myname>/NAS
No luck with that, either.
Then I tried
Code:
sshfs <username>@IP-NAS:/raid0/data/<username> /home/<myname>/NAS
and that worked. So within the network the ssh-connection works if I don't indicate the port number.
That comforts me a bit, but there is still way to go to get the connection working from outside the network, it seems.
Reply
#15
(05-22-2017, 01:52 PM)outkastm Wrote: FaJoSSHD is actually OpenSSH, so you can look on the docs for that. https://www.openssh.com
in /etc/passwd file, for the user you want to give access change the end of the line from :/dev/null to :/bin/bash.
FaJoSSH is setup default to work on port 10022. If you want to use it on port 22, stop SSH service from Thecus WebUI, change the port in FaJoSSHD config file and restart the module

Thank you for that information. I will try to figure out the thing with public keys etc., so that logging in can be disabled over ssh. But still I'm not able to login via the Internet using sshfs. It's also a bit confusing with FaJoSSHD being there while the Thecus also has ssh - in the module folder one can find the same configuration files but with (partly) different settings. I'm not sure if the Thecus SSH is being used or FaJoSSHD.
Well, there's a lot to learn, I'm sure. And with my almost 60 years it takes a little time. Thanks for your patience.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)