Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
N4200PRO OLED burnout, twice!
#1
Shocked 
Hello,

I have a N4200PRO that has been my NAS workhorse for many years. Recently I turned it off for a week while I moved some equipment around and when I powered it back on I was shocked to see the OLED display no longer working. I powered it off and pull the front fascia apart to find that the OLED display had burned out near the connector  Confused

My neighbor had the same NAS that had a motherboard die so he gave it to me for spares so I swapped out the module and upgraded the OLED Firmware with V013 and it was working great once again, I left it running on my bench for a few days before powering it off once more and left it off for a few days.
Last night I moved it to its new location and I was shocked to find out that the replacement OLED display has burned out again!  Angry

Attached is an image of it. Is this the backup battery doing this on power off and discharging through the display? I have no idea why this has happened and I'm now worried about replacing it again, that's if I can even find a replacement display after being so lucky to have a spare.

Any help appreciated.

-Wastey  Huh

[Image: 2017_03_13_22_50_56.jpg]
Reply
#2
Dear Sir

This N4200PRO should over 5 or 6 years old, maybe it is time for a new NAS, if you would like to buy a new Thecus NAS, please contact your Thecus account manager or Thecus office and we will be glad provide special offer for you.
http://www.thecus.com/about_contact.php
Yvon.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)