Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thecus NAS Linux based and Google Drive and Acronis True Image
#1
Exclamation 
Connected a windows share to a NAS Linux v5 Based Thecus N4100, N5500, N7700, and N8800.

Google Drive reported the directory was not writeable. A quick look and all folders had a black square in read only. Took a look at the security tab and the only full control was for the NAS accounts. All windows account permissions that Google drive relies on were blank and unchangeable. This is by design for Linux NAS permission in Windows. No I cant change everyone to full control..

As google drive has no explicit NAS Linux account the only option was to have the NAS run in public permission mode. Yes google drive now installs.

But it's not a good fix. Acronis True Image Home backup can not log into the NAS. It wants a Linux account to browse despite it being public. But the public NAS has no account! No I can not make a Linux user and get google drive to work.

Someone suggested "this sounds like the old "aligning the Windows and Linux account" problem. As it sounds like a 2 decade old issue I'll keep it short. Why not try the logins aligned. That is if I login on my Windows as Sally, why don't I have a matching Sally account on Linux?"

I can't align the logon as I use an email address for windows account sync.
Reply
#2
(10-04-2016, 08:58 AM)bootit Wrote: Connected a windows share to a NAS Linux v5 Based Thecus N4100, N5500, N7700, and N8800.

Google Drive reported the directory was not writeable. A quick look and all folders had a black square in read only. Took a look at the security tab and the only full control was for the NAS accounts. All windows account permissions that Google drive relies on were blank and unchangeable. This is by design for Linux NAS permission in Windows. No I cant change everyone to full control..

As google drive has no explicit NAS Linux account the only option was to have the NAS run in public permission mode. Yes google drive now installs.

But it's not a good fix. Acronis True Image Home backup can not log into the NAS. It wants a Linux account to browse despite it being public. But the public NAS has no account! No I can not make a Linux user and get google drive to work.

Someone suggested "this sounds like the old "aligning the Windows and Linux account" problem. As it sounds like a 2 decade old issue I'll keep it short. Why not try the logins aligned. That is if I login on my Windows as Sally, why don't I have a matching Sally account on Linux?"

I can't align the logon as I use an email address for windows account sync.

Solution is due to Man-In-The-Middle attack - Win10 security

Someone told me to follow this post

https://techjourney.net/cannot-connect-t...indows-10/

Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10
Home»Operating Systems»Windows»Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10
In Windows 10, especially after upgrading to Windows 10 build 9926 released on January 2015 or later, you may encounter the following error when attempting to access remote shared folders or network locations on a file server or NAS through CIFS, SMB or Samba protocol. The remote network locations or shared folders have been working all along, and continue to work and accessible for workstations running Windows 8.1, Windows 8, Windows 7, Windows Vista, Windows XP and older Windows versions.

\\Remote-Server\Path is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

To re-enable the guest access to remote shared folders and network locations in Windows 10:

Run Registry Editor (REGEDIT).
Navigate to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
Right click on the Parameters key name, and select New -> DWORD (32-bit) Value.

New DWORD (32-bit) Value
Name the new value as AllowInsecureGuestAuth and set its Hex value data to 1.

AllowInsecureGuestAuth
You should be able to access CIFS / SMB / Samba network shares instantly without login.

Update: If you’re using a Microsoft Account (MSA) to sign into Windows 10, you may also need to create a domain user account with proper access permissions configured in Samba or Windows Shared Folders on the remote server for authentication purpose, as Windows 10 may assume those logging in with MSA as domain users and requires higher trust level for security.

The solution is to create a local user that had the same username with Microsoft Account (the emailaddress@outlook.com or emailaddress@hotmail.com email address) used to sign onto Windows 10. In Windows, you can use Control Panel or PC Settings app to create a new local user account, while in Linux, uses useradd, passwd, and usermod to create the local user account, set its password and add it to the user groups which has the access rights in Samba.

Once you added the user account in remote server to connect to, time to add the user credentials for the network share to your system. To do so:

Open Power Users Quick Access menu and select Control Panel.
Go to User Accounts.
Click or tap on Manage Windows Credentials. Or, go to Credentials Manager then Windows Credentials tab.
Click or tap on Add a Windows credential.

Add a Windows Credential
Enter the remote server computer name as the Internet or network address, and then enter the user name and password similar to MSA created on the remote server.

Add Windows Credential
Hit OK when done.

You can now try to connect to network shared folders.

I was able to change the registry and now have security for everyone as Full. I tried to follow https://techjourney.net/cannot-connect-t...indows-10/ however the update section can not be followed as the v5 inux NAS does not support Microsoft email adresses as the logon ie hte @ sign is rejected as an error. So I can do backups but not access any files by Google Drive. Now I have found I can't access files using PaperPort pdf products. I imagine many softwares will fail as I use them!

I am unsure how to remove email addresses from the workstations and what problems it wil bring. I have 6 user profile logons based on emails that move between 5 workstations.

Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders

I discovered this issue is also discussed here however the Windows Credential Manager changed did not do enough to get it to work.

http://answers.microsoft.com/en-us/insid...469&auth=1
[url=http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_web/fix-windows-10-and-network-share-problems/f9b6d62d-839f-49a4-8fe9-7becc01aa911?tm=1435842396469&auth=1][/url]
Reply
#3
(10-04-2016, 10:46 PM)bootit Wrote:
(10-04-2016, 08:58 AM)bootit Wrote: Connected a windows share to a NAS Linux v5 Based Thecus N4100, N5500, N7700, and N8800.

Google Drive reported the directory was not writeable. A quick look and all folders had a black square in read only. Took a look at the security tab and the only full control was for the NAS accounts. All windows account permissions that Google drive relies on were blank and unchangeable. This is by design for Linux NAS permission in Windows. No I cant change everyone to full control..

As google drive has no explicit NAS Linux account the only option was to have the NAS run in public permission mode. Yes google drive now installs.

But it's not a good fix. Acronis True Image Home backup can not log into the NAS. It wants a Linux account to browse despite it being public. But the public NAS has no account! No I can not make a Linux user and get google drive to work.

Someone suggested "this sounds like the old "aligning the Windows and Linux account" problem. As it sounds like a 2 decade old issue I'll keep it short. Why not try the logins aligned. That is if I login on my Windows as Sally, why don't I have a matching Sally account on Linux?"

I can't align the logon as I use an email address for windows account sync.

Solution is due to Man-In-The-Middle attack - Win10 security

Someone told me to follow this post

https://techjourney.net/cannot-connect-t...indows-10/

Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10
Home»Operating Systems»Windows»Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10
In Windows 10, especially after upgrading to Windows 10 build 9926 released on January 2015 or later, you may encounter the following error when attempting to access remote shared folders or network locations on a file server or NAS through CIFS, SMB or Samba protocol. The remote network locations or shared folders have been working all along, and continue to work and accessible for workstations running Windows 8.1, Windows 8, Windows 7, Windows Vista, Windows XP and older Windows versions.

\\Remote-Server\Path is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

To re-enable the guest access to remote shared folders and network locations in Windows 10:

Run Registry Editor (REGEDIT).
Navigate to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
Right click on the Parameters key name, and select New -> DWORD (32-bit) Value.

New DWORD (32-bit) Value
Name the new value as AllowInsecureGuestAuth and set its Hex value data to 1.

AllowInsecureGuestAuth
You should be able to access CIFS / SMB / Samba network shares instantly without login.

Update: If you’re using a Microsoft Account (MSA) to sign into Windows 10, you may also need to create a domain user account with proper access permissions configured in Samba or Windows Shared Folders on the remote server for authentication purpose, as Windows 10 may assume those logging in with MSA as domain users and requires higher trust level for security.

The solution is to create a local user that had the same username with Microsoft Account (the emailaddress@outlook.com or emailaddress@hotmail.com email address) used to sign onto Windows 10. In Windows, you can use Control Panel or PC Settings app to create a new local user account, while in Linux, uses useradd, passwd, and usermod to create the local user account, set its password and add it to the user groups which has the access rights in Samba.

Once you added the user account in remote server to connect to, time to add the user credentials for the network share to your system. To do so:

Open Power Users Quick Access menu and select Control Panel.
Go to User Accounts.
Click or tap on Manage Windows Credentials. Or, go to Credentials Manager then Windows Credentials tab.
Click or tap on Add a Windows credential.

Add a Windows Credential
Enter the remote server computer name as the Internet or network address, and then enter the user name and password similar to MSA created on the remote server.

Add Windows Credential
Hit OK when done.

You can now try to connect to network shared folders.

I was able to change the registry and now have security for everyone as Full. I tried to follow https://techjourney.net/cannot-connect-t...indows-10/ however the update section can not be followed as the v5 inux NAS does not support Microsoft email adresses as the logon ie hte @ sign is rejected as an error. So I can do backups but not access any files by Google Drive. Now I have found I can't access files using PaperPort pdf products. I imagine many softwares will fail as I use them!

I am unsure how to remove email addresses from the workstations and what problems it wil bring. I have 6 user profile logons based on emails that move between 5 workstations.

Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders

I discovered this issue is also discussed here however the Windows Credential Manager changed did not do enough to get it to work.

http://answers.microsoft.com/en-us/insid...469&auth=1
[/url]

Local Login Aligned to Linux NAS share still problematic

I am now using a local login nothing has changed.

Acronis True Image Backup only works when using non public credentialed share. That stops Google Drive.

The google account only works when using a public share, That stop Acronis.

What is rather strange is that a post from google says some shares are not supported for google drive.

https://support.google.com/a/answer/2490101?hl=en

"Google Drive for Mac/PC supports only HFS+ (on OS X) and NTFS (on Windows) file systems. There's currently no support for network volumes (e.g. SMB or NFS) or other file systems, such as FAT32."

I cant work out how the google drive works on my Linux NAS when the share is public.

I am now thinking of either:
1.
Following a suggestion that I "Use a local login or create a login script that makes the connection" and "A login script to connect. It's possibly one line long (NET USE) and I am left to guess the admin is just new or in need of more admin server classes."

2.
Installing Google drive drive on an iSCSI thin client for each user and formatting to NTFS so its local and overcomes share issues whatever system the Linux NAS box is using for windows.

(10-05-2016, 12:39 PM)bootit Wrote:
(10-04-2016, 10:46 PM)bootit Wrote:
(10-04-2016, 08:58 AM)bootit Wrote: Connected a windows share to a NAS Linux v5 Based Thecus N4100, N5500, N7700, and N8800.

Google Drive reported the directory was not writeable. A quick look and all folders had a black square in read only. Took a look at the security tab and the only full control was for the NAS accounts. All windows account permissions that Google drive relies on were blank and unchangeable. This is by design for Linux NAS permission in Windows. No I cant change everyone to full control..

As google drive has no explicit NAS Linux account the only option was to have the NAS run in public permission mode. Yes google drive now installs.

But it's not a good fix. Acronis True Image Home backup can not log into the NAS. It wants a Linux account to browse despite it being public. But the public NAS has no account! No I can not make a Linux user and get google drive to work.

Someone suggested "this sounds like the old "aligning the Windows and Linux account" problem. As it sounds like a 2 decade old issue I'll keep it short. Why not try the logins aligned. That is if I login on my Windows as Sally, why don't I have a matching Sally account on Linux?"

I can't align the logon as I use an email address for windows account sync.

Solution is due to Man-In-The-Middle attack - Win10 security

Someone told me to follow this post

https://techjourney.net/cannot-connect-to-cifs-smb-samba-network-shares-shared-folders-in-windows-10/

Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10
Home»Operating Systems»Windows»Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10
In Windows 10, especially after upgrading to Windows 10 build 9926 released on January 2015 or later, you may encounter the following error when attempting to access remote shared folders or network locations on a file server or NAS through CIFS, SMB or Samba protocol. The remote network locations or shared folders have been working all along, and continue to work and accessible for workstations running Windows 8.1, Windows 8, Windows 7, Windows Vista, Windows XP and older Windows versions.

\\Remote-Server\Path is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

To re-enable the guest access to remote shared folders and network locations in Windows 10:

Run Registry Editor (REGEDIT).
Navigate to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
Right click on the Parameters key name, and select New -> DWORD (32-bit) Value.

New DWORD (32-bit) Value
Name the new value as AllowInsecureGuestAuth and set its Hex value data to 1.

AllowInsecureGuestAuth
You should be able to access CIFS / SMB / Samba network shares instantly without login.

Update: If you’re using a Microsoft Account (MSA) to sign into Windows 10, you may also need to create a domain user account with proper access permissions configured in Samba or Windows Shared Folders on the remote server for authentication purpose, as Windows 10 may assume those logging in with MSA as domain users and requires higher trust level for security.

The solution is to create a local user that had the same username with Microsoft Account (the emailaddress@outlook.com or emailaddress@hotmail.com email address) used to sign onto Windows 10. In Windows, you can use Control Panel or PC Settings app to create a new local user account, while in Linux, uses useradd, passwd, and usermod to create the local user account, set its password and add it to the user groups which has the access rights in Samba.

Once you added the user account in remote server to connect to, time to add the user credentials for the network share to your system. To do so:

Open Power Users Quick Access menu and select Control Panel.
Go to User Accounts.
Click or tap on Manage Windows Credentials. Or, go to Credentials Manager then Windows Credentials tab.
Click or tap on Add a Windows credential.

Add a Windows Credential
Enter the remote server computer name as the Internet or network address, and then enter the user name and password similar to MSA created on the remote server.

Add Windows Credential
Hit OK when done.

You can now try to connect to network shared folders.

I was able to change the registry and now have security for everyone as Full. I tried to follow https://techjourney.net/cannot-connect-t...indows-10/ however the update section can not be followed as the v5 inux NAS does not support Microsoft email adresses as the logon ie hte @ sign is rejected as an error. So I can do backups but not access any files by Google Drive. Now I have found I can't access files using PaperPort pdf products. I imagine many softwares will fail as I use them!

I am unsure how to remove email addresses from the workstations and what problems it wil bring. I have 6 user profile logons based on emails that move between 5 workstations.

Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders

I discovered this issue is also discussed here however the Windows Credential Manager changed did not do enough to get it to work.

http://answers.microsoft.com/en-us/insid...469&auth=1
[url=http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_web/fix-windows-10-and-network-share-problems/f9b6d62d-839f-49a4-8fe9-7becc01aa911?tm=1435842396469&auth=1]

Local Login Aligned to Linux NAS share still problematic

I am now using a local login nothing has changed.

Acronis True Image Backup only works when using non public credentialed share. That stops Google Drive.

The google account only works when using a public share, That stop Acronis.

What is rather strange is that a post from google says some shares are not supported for google drive.

https://support.google.com/a/answer/2490101?hl=en

"Google Drive for Mac/PC supports only HFS+ (on OS X) and NTFS (on Windows) file systems. There's currently no support for network volumes (e.g. SMB or NFS) or other file systems, such as FAT32."

I cant work out how the google drive works on my Linux NAS when the share is public.

I am now thinking of either:
1.
Following a suggestion that I "Use a local login or create a login script that makes the connection" and "A login script to connect. It's possibly one line long (NET USE) and I am left to guess the admin is just new or in need of more admin server classes."

2.
Installing Google drive drive on an iSCSI thin client for each user and formatting to NTFS so its local and overcomes share issues whatever system the Linux NAS box is using for windows.

Im thinking of trying this scripting

Net Use for persistent share on Linux NAS share

I assume you make a bat script from these type of commands

http://ss64.com/nt/net_use.html

Map a drive letter to a remote server/share.

Syntax
NET USE [devicename | *] [\\computername\sharename[\volume] [password | *]]
[/USER:[domainname\]username]
[/USER:[dotted domain name\]username]
[/USER:[username@dotted domain name]
[/SMARTCARD] [/SAVECRED] [[/DELETE] | [/PERSISTENT:{YES | NO}]]

Map to the current user's home directory as specified in the users Active Directory record:
NET USE {devicename | *} [password | *] /HOME

Set defaults:
NET USE [/PERSISTENT:{YES | NO}]
Reply
#4
(10-05-2016, 12:39 PM)bootit Wrote:
(10-04-2016, 10:46 PM)bootit Wrote:
(10-04-2016, 08:58 AM)bootit Wrote: Connected a windows share to a NAS Linux v5 Based Thecus N4100, N5500, N7700, and N8800.

Google Drive reported the directory was not writeable. A quick look and all folders had a black square in read only. Took a look at the security tab and the only full control was for the NAS accounts. All windows account permissions that Google drive relies on were blank and unchangeable. This is by design for Linux NAS permission in Windows. No I cant change everyone to full control..

As google drive has no explicit NAS Linux account the only option was to have the NAS run in public permission mode. Yes google drive now installs.

But it's not a good fix. Acronis True Image Home backup can not log into the NAS. It wants a Linux account to browse despite it being public. But the public NAS has no account! No I can not make a Linux user and get google drive to work.

Someone suggested "this sounds like the old "aligning the Windows and Linux account" problem. As it sounds like a 2 decade old issue I'll keep it short. Why not try the logins aligned. That is if I login on my Windows as Sally, why don't I have a matching Sally account on Linux?"

I can't align the logon as I use an email address for windows account sync.

Solution is due to Man-In-The-Middle attack - Win10 security

Someone told me to follow this post

https://techjourney.net/cannot-connect-t...indows-10/

Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10
Home»Operating Systems»Windows»Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10
In Windows 10, especially after upgrading to Windows 10 build 9926 released on January 2015 or later, you may encounter the following error when attempting to access remote shared folders or network locations on a file server or NAS through CIFS, SMB or Samba protocol. The remote network locations or shared folders have been working all along, and continue to work and accessible for workstations running Windows 8.1, Windows 8, Windows 7, Windows Vista, Windows XP and older Windows versions.

\\Remote-Server\Path is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

To re-enable the guest access to remote shared folders and network locations in Windows 10:

Run Registry Editor (REGEDIT).
Navigate to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
Right click on the Parameters key name, and select New -> DWORD (32-bit) Value.

New DWORD (32-bit) Value
Name the new value as AllowInsecureGuestAuth and set its Hex value data to 1.

AllowInsecureGuestAuth
You should be able to access CIFS / SMB / Samba network shares instantly without login.

Update: If you’re using a Microsoft Account (MSA) to sign into Windows 10, you may also need to create a domain user account with proper access permissions configured in Samba or Windows Shared Folders on the remote server for authentication purpose, as Windows 10 may assume those logging in with MSA as domain users and requires higher trust level for security.

The solution is to create a local user that had the same username with Microsoft Account (the emailaddress@outlook.com or emailaddress@hotmail.com email address) used to sign onto Windows 10. In Windows, you can use Control Panel or PC Settings app to create a new local user account, while in Linux, uses useradd, passwd, and usermod to create the local user account, set its password and add it to the user groups which has the access rights in Samba.

Once you added the user account in remote server to connect to, time to add the user credentials for the network share to your system. To do so:

Open Power Users Quick Access menu and select Control Panel.
Go to User Accounts.
Click or tap on Manage Windows Credentials. Or, go to Credentials Manager then Windows Credentials tab.
Click or tap on Add a Windows credential.

Add a Windows Credential
Enter the remote server computer name as the Internet or network address, and then enter the user name and password similar to MSA created on the remote server.

Add Windows Credential
Hit OK when done.

You can now try to connect to network shared folders.

I was able to change the registry and now have security for everyone as Full. I tried to follow https://techjourney.net/cannot-connect-t...indows-10/ however the update section can not be followed as the v5 inux NAS does not support Microsoft email adresses as the logon ie hte @ sign is rejected as an error. So I can do backups but not access any files by Google Drive. Now I have found I can't access files using PaperPort pdf products. I imagine many softwares will fail as I use them!

I am unsure how to remove email addresses from the workstations and what problems it wil bring. I have 6 user profile logons based on emails that move between 5 workstations.

Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders

I discovered this issue is also discussed here however the Windows Credential Manager changed did not do enough to get it to work.

http://answers.microsoft.com/en-us/insid...469&auth=1
[/url]

Local Login Aligned to Linux NAS share still problematic

I am now using a local login nothing has changed.

Acronis True Image Backup only works when using non public credentialed share. That stops Google Drive.

The google account only works when using a public share, That stop Acronis.

What is rather strange is that a post from google says some shares are not supported for google drive.

https://support.google.com/a/answer/2490101?hl=en

"Google Drive for Mac/PC supports only HFS+ (on OS X) and NTFS (on Windows) file systems. There's currently no support for network volumes (e.g. SMB or NFS) or other file systems, such as FAT32."

I cant work out how the google drive works on my Linux NAS when the share is public.

I am now thinking of either:
1.
Following a suggestion that I "Use a local login or create a login script that makes the connection" and "A login script to connect. It's possibly one line long (NET USE) and I am left to guess the admin is just new or in need of more admin server classes."

2.
Installing Google drive drive on an iSCSI thin client for each user and formatting to NTFS so its local and overcomes share issues whatever system the Linux NAS box is using for windows.

(10-05-2016, 12:39 PM)bootit Wrote:
(10-04-2016, 10:46 PM)bootit Wrote:
(10-04-2016, 08:58 AM)bootit Wrote: Connected a windows share to a NAS Linux v5 Based Thecus N4100, N5500, N7700, and N8800.

Google Drive reported the directory was not writeable. A quick look and all folders had a black square in read only. Took a look at the security tab and the only full control was for the NAS accounts. All windows account permissions that Google drive relies on were blank and unchangeable. This is by design for Linux NAS permission in Windows. No I cant change everyone to full control..

As google drive has no explicit NAS Linux account the only option was to have the NAS run in public permission mode. Yes google drive now installs.

But it's not a good fix. Acronis True Image Home backup can not log into the NAS. It wants a Linux account to browse despite it being public. But the public NAS has no account! No I can not make a Linux user and get google drive to work.

Someone suggested "this sounds like the old "aligning the Windows and Linux account" problem. As it sounds like a 2 decade old issue I'll keep it short. Why not try the logins aligned. That is if I login on my Windows as Sally, why don't I have a matching Sally account on Linux?"

I can't align the logon as I use an email address for windows account sync.

Solution is due to Man-In-The-Middle attack - Win10 security

Someone told me to follow this post

https://techjourney.net/cannot-connect-to-cifs-smb-samba-network-shares-shared-folders-in-windows-10/

Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10
Home»Operating Systems»Windows»Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10
In Windows 10, especially after upgrading to Windows 10 build 9926 released on January 2015 or later, you may encounter the following error when attempting to access remote shared folders or network locations on a file server or NAS through CIFS, SMB or Samba protocol. The remote network locations or shared folders have been working all along, and continue to work and accessible for workstations running Windows 8.1, Windows 8, Windows 7, Windows Vista, Windows XP and older Windows versions.

\\Remote-Server\Path is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

To re-enable the guest access to remote shared folders and network locations in Windows 10:

Run Registry Editor (REGEDIT).
Navigate to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
Right click on the Parameters key name, and select New -> DWORD (32-bit) Value.

New DWORD (32-bit) Value
Name the new value as AllowInsecureGuestAuth and set its Hex value data to 1.

AllowInsecureGuestAuth
You should be able to access CIFS / SMB / Samba network shares instantly without login.

Update: If you’re using a Microsoft Account (MSA) to sign into Windows 10, you may also need to create a domain user account with proper access permissions configured in Samba or Windows Shared Folders on the remote server for authentication purpose, as Windows 10 may assume those logging in with MSA as domain users and requires higher trust level for security.

The solution is to create a local user that had the same username with Microsoft Account (the emailaddress@outlook.com or emailaddress@hotmail.com email address) used to sign onto Windows 10. In Windows, you can use Control Panel or PC Settings app to create a new local user account, while in Linux, uses useradd, passwd, and usermod to create the local user account, set its password and add it to the user groups which has the access rights in Samba.

Once you added the user account in remote server to connect to, time to add the user credentials for the network share to your system. To do so:

Open Power Users Quick Access menu and select Control Panel.
Go to User Accounts.
Click or tap on Manage Windows Credentials. Or, go to Credentials Manager then Windows Credentials tab.
Click or tap on Add a Windows credential.

Add a Windows Credential
Enter the remote server computer name as the Internet or network address, and then enter the user name and password similar to MSA created on the remote server.

Add Windows Credential
Hit OK when done.

You can now try to connect to network shared folders.

I was able to change the registry and now have security for everyone as Full. I tried to follow https://techjourney.net/cannot-connect-t...indows-10/ however the update section can not be followed as the v5 inux NAS does not support Microsoft email adresses as the logon ie hte @ sign is rejected as an error. So I can do backups but not access any files by Google Drive. Now I have found I can't access files using PaperPort pdf products. I imagine many softwares will fail as I use them!

I am unsure how to remove email addresses from the workstations and what problems it wil bring. I have 6 user profile logons based on emails that move between 5 workstations.

Cannot Connect to CIFS / SMB / Samba Network Shares & Shared Folders

I discovered this issue is also discussed here however the Windows Credential Manager changed did not do enough to get it to work.

http://answers.microsoft.com/en-us/insid...469&auth=1
[url=http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_web/fix-windows-10-and-network-share-problems/f9b6d62d-839f-49a4-8fe9-7becc01aa911?tm=1435842396469&auth=1]

Local Login Aligned to Linux NAS share still problematic

I am now using a local login nothing has changed.

Acronis True Image Backup only works when using non public credentialed share. That stops Google Drive.

The google account only works when using a public share, That stop Acronis.

What is rather strange is that a post from google says some shares are not supported for google drive.

https://support.google.com/a/answer/2490101?hl=en

"Google Drive for Mac/PC supports only HFS+ (on OS X) and NTFS (on Windows) file systems. There's currently no support for network volumes (e.g. SMB or NFS) or other file systems, such as FAT32."

I cant work out how the google drive works on my Linux NAS when the share is public.

I am now thinking of either:
1.
Following a suggestion that I "Use a local login or create a login script that makes the connection" and "A login script to connect. It's possibly one line long (NET USE) and I am left to guess the admin is just new or in need of more admin server classes."

2.
Installing Google drive drive on an iSCSI thin client for each user and formatting to NTFS so its local and overcomes share issues whatever system the Linux NAS box is using for windows.

Im thinking of trying this scripting

Net Use for persistent share on Linux NAS share

I assume you make a bat script from these type of commands

http://ss64.com/nt/net_use.html

Map a drive letter to a remote server/share.

Syntax
NET USE [devicename | *] [\\computername\sharename[\volume] [password | *]]
[/USER:[domainname\]username]
[/USER:[dotted domain name\]username]
[/USER:[username@dotted domain name]
[/SMARTCARD] [/SAVECRED] [[/DELETE] | [/PERSISTENT:{YES | NO}]]

Map to the current user's home directory as specified in the users Active Directory record:
NET USE {devicename | *} [password | *] /HOME

Set defaults:
NET USE [/PERSISTENT:{YES | NO}]

Someone suggested this

Well, Linux/Unix username/password and the Microsoft equivalent do not operate in the same way.  These email or Domain username/passowrds are a relative newcomer to the scene.  Some applicaitons like skype for example have already embraced the Microsoft account and have made it possible to login to their services using a Microsoft account.

My quess here is that Thecus would need to develope (they may already have) a mapping mechanism that allows a Microsoft account to be mapped to an existing user account on Thecus devices.  Have you investigated if Thecus has modified the software and or firmware update that might address this?  Thecus may have some other workaround for this as well so I would check with them on this issue.

Support for this particular issue here on this Forum is going to be very limited.  I am not an expert on this by any means and can only offer a minimum of solution based advice.

I am not familiar with the Thecus based products so am unsure if you have any access to the Linux shell from which you could attempt manual mapping of an existing Linux account to that of a Microsoft account.  Be advised that even if you have or can access the Linux shell the below example of manual mapping may not work as it is dependent on the version of SAMBA installed.

Username mapping Example:

You can add a line in /etc/samba/smbusers:

Code: linux_name = windows_name1, windows_name2 <etc.>

This maps windows name(s) to a linux name. You may also need to add this parameter to the [global] section of:
/etc/samba/smb.conf.

Code: username map = /etc/samba/smbusers

You can check if it is necessary to add the above parameter to your smb.conf with:

Code: testparm -vs | grep "username map"
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)